Search Results (7 CVEs found)

CVE Vendors Products Updated CVSS v3.1
CVE-2025-11841 2 Greenshiftwp, Wordpress 2 Greenshift - Animation And Page Builder Blocks, Wordpress 2026-04-21 6.4 Medium
The Greenshift – animation and page builder blocks plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the Chart Data attributes in all versions up to, and including, 12.2.7 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
CVE-2025-3616 1 Greenshiftwp 1 Greenshift - Animation And Page Builder Blocks 2025-05-28 8.8 High
The Greenshift – animation and page builder blocks plugin for WordPress is vulnerable to arbitrary file uploads due to missing file type validation in the gspb_make_proxy_api_request() function in versions 11.4 to 11.4.5. This makes it possible for authenticated attackers, with Subscriber-level access and above, to upload arbitrary files on the affected site's server which may make remote code execution possible. The arbitrary file upload was sufficiently patched in 11.4.5, but a capability check was added in 11.4.6 to properly prevent unauthorized limited file uploads.
CVE-2023-22707 1 Greenshiftwp 1 Greenshift - Animation And Page Builder Blocks 2025-01-10 5.9 Medium
Auth. (author+) Cross-Site Scripting (XSS) vulnerability in Wpsoul Greenshift – animation and page builder blocks plugin <= 4.9.9 versions.
CVE-2023-6636 1 Greenshiftwp 1 Greenshift - Animation And Page Builder Blocks 2024-11-21 7.2 High
The Greenshift – animation and page builder blocks plugin for WordPress is vulnerable to arbitrary file uploads due to missing file type validation on the 'gspb_save_files' function in versions up to, and including, 7.6.2. This makes it possible for authenticated attackers with administrator-level capabilities or above, to upload arbitrary files on the affected site's server which may make remote code execution possible.
CVE-2023-0378 1 Greenshiftwp 1 Greenshift - Animation And Page Builder Blocks 2024-11-21 5.4 Medium
The Greenshift WordPress plugin before 5.0 does not validate and escape some of its block options before outputting them back in a page/post where the block is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks.
CVE-2022-4653 1 Greenshiftwp 1 Greenshift - Animation And Page Builder Blocks 2024-11-21 5.4 Medium
The Greenshift WordPress plugin before 4.8.9 does not validate and escape one of its shortcode attributes, which could allow users with a role as low as contributor to perform Stored Cross-Site Scripting attack.
CVE-2024-44005 1 Greenshiftwp 1 Greenshift - Animation And Page Builder Blocks 2024-09-25 6.5 Medium
Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in Wpsoul Greenshift – animation and page builder blocks allows Stored XSS.This issue affects Greenshift – animation and page builder blocks: from n/a through 9.3.7.