Search Results (3855 CVEs found)

CVE Vendors Products Updated CVSS v3.1
CVE-2017-16065 1 Openssl.js Project 1 Openssl.js 2024-09-17 N/A
openssl.js was a malicious module published with the intent to hijack environment variables. It has been unpublished by npm.
CVE-2018-1000827 1 Ubilling 1 Ubilling 2024-09-17 N/A
Ubilling version <= 0.9.2 contains a Other/Unknown vulnerability in user-controlled parameter that can result in Disclosure of confidential data, denial of service, SSRF, remote code execution.
CVE-2022-25863 1 Gatsbyjs 1 Gatsby 2024-09-17 8.1 High
The package gatsby-plugin-mdx before 2.14.1, from 3.0.0 and before 3.15.2 are vulnerable to Deserialization of Untrusted Data when passing input through to the gray-matter package, due to its default configurations that are missing input sanitization. Exploiting this vulnerability is possible when passing input in both webpack (MDX files in src/pages or MDX file imported as a component in frontend / React code) and data mode (querying MDX nodes via GraphQL). Workaround: If an older version of gatsby-plugin-mdx must be used, input passed into the plugin should be sanitized ahead of processing.
CVE-2018-3972 1 Getmonero 1 Monero 2024-09-17 9.8 Critical
An exploitable code execution vulnerability exists in the Levin deserialization functionality of the Epee library, as used in Monero 'Lithium Luna' (v0.12.2.0-master-ffab6700) and other cryptocurrencies. A specially crafted network packet can cause a logic flaw, resulting in code execution. An attacker can send a packet to trigger this vulnerability.
CVE-2017-16044 1 D3.js Project 1 D3.js 2024-09-17 N/A
`d3.js` was a malicious module published with the intent to hijack environment variables. It has been unpublished by npm.
CVE-2021-29781 2 Ibm, Linux 2 Partner Engagement Manager, Linux Kernel 2024-09-17 9.8 Critical
IBM Partner Engagement Manager 2.0 could allow a remote attacker to execute arbitrary code on the system, caused by an unsafe deserialization flaw. By sending specially-crafted data, an attacker could exploit this vulnerability to execute arbitrary code on the system. IBM X-Force ID: 203091.
CVE-2017-16057 1 Nodemssql Project 1 Nodemssql 2024-09-17 N/A
nodemssql was a malicious module published with the intent to hijack environment variables. It has been unpublished by npm.
CVE-2017-16076 1 Proxy.js Project 1 Proxy.js 2024-09-17 N/A
proxy.js was a malicious module published with the intent to hijack environment variables. It has been unpublished by npm.
CVE-2017-16059 1 Mssql-node Project 1 Mssql-node 2024-09-17 N/A
mssql-node was a malicious module published with the intent to hijack environment variables. It has been unpublished by npm.
CVE-2017-8965 1 Hp 1 Intelligent Management Center 2024-09-16 N/A
A Deserialization of Untrusted Data vulnerability in Hewlett Packard Enterprise Intelligent Management Center (iMC) PLAT version 7.3 E0504P2 was found.
CVE-2017-2292 1 Puppet 1 Mcollective 2024-09-16 N/A
Versions of MCollective prior to 2.10.4 deserialized YAML from agents without calling safe_load, allowing the potential for arbitrary code execution on the server. The fix for this is to call YAML.safe_load on input. This has been tested in all Puppet-supplied MCollective plugins, but there is a chance that third-party plugins could rely on this insecure behavior.
CVE-2019-11286 1 Vmware 2 Gemfire, Tanzu Gemfire For Virtual Machines 2024-09-16 9.1 Critical
VMware GemFire versions prior to 9.10.0, 9.9.1, 9.8.5, and 9.7.5, and VMware Tanzu GemFire for VMs versions prior to 1.11.0, 1.10.1, 1.9.2, and 1.8.2, contain a JMX service available to the network which does not properly restrict input. A remote authenticated malicious user may request against the service with a crafted set of credentials leading to remote code execution.
CVE-2017-12558 1 Hp 1 Intelligent Management Center 2024-09-16 N/A
A Remote Code Execution vulnerability in HPE intelligent Management Center (iMC) PLAT version IMC Plat 7.3 E0504P2 and earlier was found.
CVE-2017-16054 1 Nodefabric Project 1 Nodefabric 2024-09-16 N/A
`nodefabric` was a malicious module published with the intent to hijack environment variables. It has been unpublished by npm.
CVE-2022-25845 3 Alibaba, Oracle, Redhat 3 Fastjson, Communications Cloud Native Core Unified Data Repository, Jboss Fuse 2024-09-16 8.1 High
The package com.alibaba:fastjson before 1.2.83 are vulnerable to Deserialization of Untrusted Data by bypassing the default autoType shutdown restrictions, which is possible under certain conditions. Exploiting this vulnerability allows attacking remote servers. Workaround: If upgrading is not possible, you can enable [safeMode](https://github.com/alibaba/fastjson/wiki/fastjson_safemode).
CVE-2018-15686 5 Canonical, Debian, Oracle and 2 more 10 Ubuntu Linux, Debian Linux, Communications Cloud Native Core Network Function Cloud Native Environment and 7 more 2024-09-16 7.8 High
A vulnerability in unit_deserialize of systemd allows an attacker to supply arbitrary state across systemd re-execution via NotifyAccess. This can be used to improperly influence systemd execution and possibly lead to root privilege escalation. Affected releases are systemd versions up to and including 239.
CVE-2017-8964 1 Hp 1 Intelligent Management Center 2024-09-16 N/A
A Deserialization of Untrusted Data vulnerability in Hewlett Packard Enterprise Intelligent Management Center (iMC) PLAT version 7.3 E0504P2 was found.
CVE-2018-1000641 1 Yeswiki 1 Yeswiki 2024-09-16 N/A
YesWiki version <= cercopitheque beta 1 contains a PHP Object Injection vulnerability in Unserialising user entered parameter in i18n.inc.php that can result in execution of code, disclosure of information.
CVE-2017-15693 1 Apache 1 Geode 2024-09-16 N/A
In Apache Geode before v1.4.0, the Geode server stores application objects in serialized form. Certain cluster operations and API invocations cause these objects to be deserialized. A user with DATA:WRITE access to the cluster may be able to cause remote code execution if certain classes are present on the classpath.
CVE-2016-9045 1 Processmaker 1 Processmaker 2024-09-16 8.8 High
A code execution vulnerability exists in ProcessMaker Enterprise Core 3.0.1.7-community. A specially crafted web request can cause unsafe deserialization potentially resulting in PHP code being executed. An attacker can send a crafted web parameter to trigger this vulnerability.